A fix has been implemented. Please reload the browser window!
Posted Dec 03, 2025 - 12:23 CET
Identified
We are currently experiencing slow servers. We will deploy a fix with the upcoming 30-60 minutes. After the deploy you will need to reload the page. If might also be necessary to restart the browser.
Posted Dec 03, 2025 - 11:31 CET
This incident affected: Webpage and Main application.